User Tools

Site Tools


informatique:wifi_public:accueil

Wi-Fi Public

J'ai toujours voulu que l'Internet soit un service gratuit et ouvert à tous. Je voulais donc que les gens aient un accès libre à l'internet aux alentours de chez moi. Aussi, le but était que les invités qui arrivent à la maison n'aient pas à rentrer un nouveau code wifi: ils se connectent au SSID public et voilà ;). Idéalement, étant un peu geek, c'est toujours sympa à faire ;)

L'accès Wi-Fi

Le truc “simple” aurait été de mettre deux points d'accès Wi-Fi sans fil, mais bon, c'est pas très propre/écolo et cie… Disposant d'un Cisco aironet 1252 (merci Jean-Marc ;) ), ce super truc peut faire un peu tout ce qu'on lui demande. Il permet donc, entre autres, de créer plusieurs SSIDs séparés (avec chacun son VLAN, etc..).

On va donc, depuis le CLI d'IOS (ouais, l'interface web, ca suxx), créer deux SSIDs séparés, puis les assigner aux deux interfaces radio avec chacun leur vlan à eux. Puis, pour terminer le tout, il faut juste “binder” les VLANs à l'interface ethernet, et voila ;)

Voici la conf, à adapter à vos besoins ! :

dot11 ssid Vi-Di.fr
   vlan 1 
   authentication open 
   authentication key-management wpa version 2
   mbssid guest-mode
   wpa-psk ascii SECRET
!
dot11 ssid Vi-Di.fr FREE
   vlan 42
   authentication open 
   mbssid guest-mode
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !        
 encryption mode ciphers aes-ccm 
 !        
 encryption vlan 1 mode ciphers aes-ccm 
 !        
 ssid Vi-Di.fr
 !        
 ssid Vi-Di.fr FREE
 !        
 antenna gain 0
 no dfs band block
 mbssid   
 channel dfs
 station-role root
!         
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!         
interface Dot11Radio0.42
 encapsulation dot1Q 42
 no ip route-cache
 bridge-group 2
 bridge-group 2 subscriber-loop-control
 bridge-group 2 block-unknown-source
 no bridge-group 2 source-learning
 no bridge-group 2 unicast-flooding
 bridge-group 2 spanning-disabled
!         
interface Dot11Radio1
 no ip address
 no ip route-cache
 !        
 encryption mode ciphers aes-ccm 
 !        
 encryption vlan 1 mode ciphers aes-ccm 
 !        
 ssid Vi-Di.fr
 !        
 ssid Vi-Di.fr FREE
 !        
 antenna gain 0
 mbssid   
 station-role root
!         
interface Dot11Radio1.1
 encapsulation dot1Q 1 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!         
interface Dot11Radio1.42
 encapsulation dot1Q 42
 no ip route-cache
 bridge-group 2
 bridge-group 2 subscriber-loop-control
 bridge-group 2 block-unknown-source
 no bridge-group 2 source-learning
 no bridge-group 2 unicast-flooding
 bridge-group 2 spanning-disabled
!         
interface GigabitEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
!         
interface GigabitEthernet0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!         
interface GigabitEthernet0.42
 encapsulation dot1Q 42
 no ip route-cache
 bridge-group 2
 no bridge-group 2 source-learning
 bridge-group 2 spanning-disabled
!         
interface BVI1
 ip address dhcp
 no ip route-cache
!
no ip http server
no ip http secure-server
bridge 1 route ip
!         
end

La config me parrait assez lisible (TODO: commenter si j'ai le temps). On obtient donc:

          Cell 01 - Address: 00:26:0B:2A:7F:10
                    Channel:2
                    Frequency:2.417 GHz (Channel 2)
                    Quality=56/70  Signal level=-54 dBm  
                    Encryption key:on
                    ESSID:"Vi-Di.fr"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
          Cell 02 - Address: 00:26:0B:2A:7F:11
                    Channel:2
                    Frequency:2.417 GHz (Channel 2)
                    Quality=56/70  Signal level=-54 dBm  
                    Encryption key:off
                    ESSID:"Vi-Di.fr FREE"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
          Cell 03 - Address: 00:26:0B:43:17:60
                    Channel:116
                    Frequency:5.58 GHz (Channel 116)
                    Quality=38/70  Signal level=-72 dBm  
                    Encryption key:on
                    ESSID:"Vi-Di.fr"
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
          Cell 04 - Address: 00:26:0B:43:17:61
                    Channel:116
                    Frequency:5.58 GHz (Channel 116)
                    Quality=38/70  Signal level=-72 dBm  
                    Encryption key:off
                    ESSID:"Vi-Di.fr FREE"
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master

Discussion

Enter your comment. Wiki syntax is allowed:
NYKKP
 
informatique/wifi_public/accueil.txt · Last modified: 2013/12/07 23:54 by frank